OpenRoads Designer CONNECT Edition SDK Help

ConnectionPointTypes Enumeration

Defines connection point types

Definition

Namespace: Bentley.CifNET.LinearGeometry Assembly: Bentley.CifNET.LinearGeometry.4.0 (in Bentley.CifNET.LinearGeometry.4.0.dll) Version: 1.0.0.0 (99.99.99.99)

C#

[FlagsAttribute]public enum ConnectionPointTypes

Members

Spiral_Spiral_SameCurvatureSign 1 At connection between two spirals describing a C curve
Spiral_Spiral_ReverseCurvatureSign 2 At connection between two spirals describing a S curve
Spiral_Spiral 3 At connection between a spirals
Spiral_Line 4 At connection between a spiral and a tangent
Spiral_CircularArc 8 At connection between a spiral and a curve
Line_Spiral 16 At connection between a tangent and a spiral
CircularArc_Spiral 32 At connection between a curve and a spiral
Curve_Curve_ReverseCurvatureSign 64 At connection between 2 curves with Reverse sign
Curve_Curve_SameCurvatureSign 128 At connection between 2 curves with same sign
Curve_Curve 192 At connection between 2 curves with same sign
Line_Curve 256 At start point of a curve from a tangent
Curve_Line 512 At end point of a curve to a tangent
Line_Line 1,024 At connection between tangents
Start 2,048 At the beginning of the element.
End 4,096 At the end of the element.
LineStringInternal 8,192 At every internal point of a line string.
All 2,147,483,647 All the points.

See Also